PCB Library Expert - USER GUIDE

Output to Xpedition

These instructions show how to import library parts into Xpedition Library Manager. This will be broken into two parts. The new Direct Import instructions as well as ASCII import for older versions of Xpedition.

Import Instructions - Encrypted ASCII or ASCII
Note: For all versions of Xpedition prior to 2007, please use regular ASCII Output for the import below, for all versions 2007 and later, use Encrypted ASCII Output for the import below.

- for versions of Xpedition (prior to VX):

1. Open Library Manager from the start menu. It is located at Mentor Graphics SDD > Data and Library Management > Library Manager.

- for older Xpedition VX:
  Open xDM Library Tools

2. If you do not already have a central library, create one by selecting File > New from Library Manager. If you already have a central library select File > Open or select your library from the list of recently opened libraries. If you already have cell partitions for importing PCB Footprint Expert parts, go to step 3; otherwise, create new partitions...

     a. Run "Setup | Partition Editor..." command.

     b. Click the New Partition icon , key in a name for the cell partition name and click Apply.

     c. Create as many Partitions as you desire.

     d. Click OK

3. Click Library Services icon

     a. Before you import Cell data files you must import Pad Stacks data files

4. Go to Tools -> Library Services. Select the Pad Stacks tab inside the Library Service window

     a. Select Import from the Operation section and select 'Pad Stack data file' from the Import from section

5. Click the Browse icon , and select the 'Pad Stacks data file'. Select the Pad Stack HKP File and click Open.

     a. All Library Expert Xpedition Output is created in the folder specified by "Output Directory"

6. All of the available pad stacks will be displayed in the left panel.

7. Use the double arrow button to move all the available pad stacks to the right panel, and then click Apply to import them

8. If these Pad Stacks are now in your Central Library, they will be indicated in blue

9. Now it's possible to import cell data files

     a. Select the Cells tab, and then select Import from the Operation section and 'Cell data file' from the Import from section

10. Choose the destination Cell Partition where to copy cells

11. Click the Browse icon , and select the 'Cell data file'. Select the Cell HKP File and click Open.

12. All the available cells will be displayed in the left panel

13. Use the double arrows to move all the available cells to the right panel, and then click Apply to import them

14. If these Cells are now in your Central Library, they will be indicated in blue

15. The cells and pad stacks have now been imported and are ready to be used.

Import Instructions - BINARY
(Preferred export is via encrypted ASCII specified above as the binary method requires two licenses of the Mentor Library Manager)

1. If you wish to import into an existing library, you must ensure there are no naming conflicts between the cells you are going to create, and the cells that are in the existing library. If any exist, and you wish to overwrite them, you must manually delete them from the library first. There should be no cells in the library manager with the same name as the parts you are generating when you are done.

2. The safest method is to simply import into a new library. In order to do this, open Xpedition Library Manager.

3. Select File/New, select the directory where you want the new library to go, and hit OK

4. You must now create a cell partition. Select Cells, Right Click, and Select 'New Partition'.

5. Enter a partition name for the parts, if it's a library you're converting, simply use the Library Name and hit OK. The library that will be imported to is the TI library folder.

6. At this point, run the translator, select Xpedition, select Direct Import, set the library name to this library (it will change the library directory automatically), and hit Create. The translator will now import the parts into the newly created library. Once again, you can do this with an existing library, you simply must ensure that no cells you are creating currently exist in the existing library. Simply delete them manually or start a new library.



TROUBLESHOOTING for Xpedition VX

LIMITATION NOTE - this limitation is for the Xpedition Direct Interface only, the Encrypted HKP option works fine. Although the values are correct, the proper units don't transfer properly directly to Xpedition. If you use "mm", you need to manually change to "mm" in Xpedition; you should already have the right values.

In order for the Direct Import to work with VX.1, you're going to need to make the following change, as well as have two available licenses of the Mentor Library Manager:

Right click on the Library Expert desktop icon and select the "Properties" option and change the "Target" to be:

C:\MentorGraphics\EEVX.1.1\SDD_HOME\common\win32\bin\mglaunch.exe "C:\Program Files (x86)\PCB Libraries\Library Expert 2015\FPX_2015_Pro.exe"

Make sure mglaunch is in that location or change the directory to your personal Xpedition path so it points to the location of mglaunch. Also make sure the path for Library Expert matches where you installed the program. Make sure Run As Administrator is turned on via the Advanced... button, then run the icon and run everything as normal and see if Direct Import into Xpedition does its thing. What it should do is launch a shell program which exposes the LibraryManager of VX to the program so that it can then interact with it, allowing it to run.

NOTE: We recommend creating a TEST partition, don't risk writing to a good one! It's recommended you have a partition dedicated to your personal work in process cells. Then you can setup your PCB Libraries install to point to your personal cell partition. You can then test or tweak the cell in the working directory before moving it to your production locations.