Print Page | Close Window

Altium Import BGA Bugs

Printed From: PCB Libraries Forum
Category: Libraries
Forum Name: Altium
Forum Description:
URL: http://www.PCBLibraries.com/forum/forum_posts.asp?TID=346
Printed Date: 06 Feb 2023 at 6:06am


Topic: Altium Import BGA Bugs
Posted By: Randy Clemmons
Subject: Altium Import BGA Bugs
Date Posted: 13 Jun 2012 at 4:45pm
Altium does not import PADs library parts for BGAs correctly.

Currently the only way to get the BGA data imported into Altium correctly is to place the BGA in a PADs design, then export the board from PADs in ASCII, then import the PCB ASCII file in to Altium.

Or you can renumber all the pins, not a lot of fun Ouch.

Here is a ticket (Bug Crunch) which I have opened at Altium.
http://bugcrunch.live.altium.com/#Bug/1826" rel="nofollow - http://bugcrunch.live.altium.com/#Bug/1826

If want this Altium Bug fixed, go to the link above nominate the ticket and cast your vote.

Let your local Altium reps know you like to have this Import Wizard fixed.

Here is my Post on the Altium Forum:

AD Still Does Not Correctly Import PADs Library for BGAs

When Altium imports PADs *.d and *p.

If the PADs part is a BGA the alpha prefixes are dropped.

A1 becomes pin 1, etc . . .

Refer to: http://bugcrunch.live.altium.com/#Bug/656" rel="nofollow - http://bugcrunch.live.altium.com/#Bug/656
Refer to: http://forum.live.altium.com/#posts/186801" rel="nofollow - http://forum.live.altium.com/#posts/186801

Altium needs to read the *.p file and set the pin designators accordingly.

Attached a sample PADs BGA part with *.d and *.p files. (files uploaded to Altium site)

http://bugcrunch.live.altium.com/#Bug/1826" rel="nofollow - http://bugcrunch.live.altium.com/#Bug/1826

You need to be a registered Altium user to go to bug crunch.

Randy





Replies:
Posted By: Randy Clemmons
Date Posted: 14 Jun 2012 at 8:05am
Solution:

When PADs *.d and *.p files are imported to Altium, the BGA Pins are numbered as 1,2 vice A1… etc.  

I have found that for Altium users it is best to output the footprints using ASCII from the PCB Footprint Tool and import in to Altium as a design (Board) vice a library using Altium Import Wizard.

Using ASCII output works perfectly, BGAs (and all other parts) will come in to Altium with the pins numbered correctly.

Here is my recommended output settings to create Altium parts.


Note you only need to re-map  four layers to match the Altium IPC Wizard defaults.

As shown above, where you see 13, 15 used these are the layer changes needed.

Randy Clemmons




Posted By: Randy Clemmons
Date Posted: 26 Jun 2012 at 4:00pm
Altium users,

You will be happy know that Altium plans to fix the PADs Import Wizard in the very near future.

This could be a a few weeks away, but I have been assured that Altium understands the value of being able to port your PADs *.p and *.d Libraries to Altium.

Until then you can import your BGAs and other alphanumeric numbered parts using ASCII output.




Posted By: Joris
Date Posted: 09 Aug 2012 at 4:17pm
Great! That would be nice.


Posted By: Joris
Date Posted: 21 Aug 2012 at 4:14pm
Any updates so far? There doesn't seem to be a lot of response from Altium.

Also can someone comment of the various PADS format versions with respect to Altium? Whats the recommended format for the various Altium Desginer versions? Maybe it would be more user friendly so show this in the dropdown as well. For example:

2007.0 (Altium 9 and down)
9.0 (Altium 10.0.123+)
9.2 (Altium 10.3.123+)
9.3 (Altium 11.0.123+)
9.4 (Not supported yet)



Posted By: Anderson
Date Posted: 14 Mar 2017 at 11:01pm
Hi ! I am also feeling problem in BGA import. Anybody get practical results then plz share here.


Posted By: Tom H
Date Posted: 15 Mar 2017 at 2:41am
Here is a BGA from Library Expert imported into Altium 17.0.11 (Build 656)
 
 


-------------
Stay connected - follow us! https://twitter.com/PCBLibraries" rel="nofollow - Twitter - http://www.linkedin.com/company/pcb-libraries-inc-/" rel="nofollow - LinkedIn


Posted By: Randy Clemmons
Date Posted: 15 Mar 2017 at 9:01am
Please note that the bug reported here is in Altium and it has to do with importing PADs libraries. 

This is not a bug in PCB libraries.  BGA's created from PCB Libraries *.fpx files come into Altium correctly.



Print Page | Close Window