Print Page | Close Window

Wrong generation of Pastе Masks in script for Alt

Printed From: PCB Libraries Forum
Category: Libraries
Forum Name: Altium
Forum Description:
URL: http://www.PCBLibraries.com/forum/forum_posts.asp?TID=2468
Printed Date: 28 Jan 2023 at 11:46pm


Topic: Wrong generation of Pastе Masks in script for Alt
Posted By: kyv4ua
Subject: Wrong generation of Pastе Masks in script for Alt
Date Posted: 08 Apr 2019 at 4:02am
Wrong generation of Pastе Masks in script for Altium

Pastе Mask in Library Expert Pro 2019.02:


Pastе Mask in Altium Designer v19.0.14 (after run script generated by Library Expert):


script generated by Library Expert:
uploads/13901/L_MUR_0402_1_L.zip" rel="nofollow - uploads/13901/L_MUR_0402_1_L.zip

where is the error, what is done wrong?



Replies:
Posted By: kyv4ua
Date Posted: 08 Apr 2019 at 4:34am
I solved the problem by creating two pads per pin:
Solder_Pad
Paste_Pad


Posted By: kyv4ua
Date Posted: 09 Apr 2019 at 5:27am
Solder_Pad

Paste_Pad




Posted By: Tom H
Date Posted: 09 Apr 2019 at 7:57am
Can you please post the URL datasheet link for this component package? 

We can't reproduce the problem and you seem to be using FP Designer incorrectly. 



-------------
Stay connected - follow us! https://twitter.com/PCBLibraries" rel="nofollow - Twitter - http://www.linkedin.com/company/pcb-libraries-inc-/" rel="nofollow - LinkedIn


Posted By: kyv4ua
Date Posted: 11 Apr 2019 at 5:35am
uploads/13901/o05e-p297.pdf" rel="nofollow - uploads/13901/o05e-p297.pdf


Posted By: Tom H
Date Posted: 11 Apr 2019 at 8:25am
In the Pad Stack Designer: 
  • The Pad Size = 0.65 X 0.35
  • Paste Mask Reduction = -0.15
  • Pad Stack Name = r65_35p35




-------------
Stay connected - follow us! https://twitter.com/PCBLibraries" rel="nofollow - Twitter - http://www.linkedin.com/company/pcb-libraries-inc-/" rel="nofollow - LinkedIn


Posted By: kyv4ua
Date Posted: 11 Apr 2019 at 8:52am
Altium can not cut the mask separately the "x" and "y" axis


Posted By: Tom H
Date Posted: 11 Apr 2019 at 9:21am
Oh, it's a limitation in Altium where the paste must be the same annular ring and therefore you cannot achieve the mfr. recommended paste mask solution. 

You must manually place the correct mfr. recommended paste mask by adding poly-regions on the paste mask layer. 

We'll have to contact Altium and alert them of this issue, because most other CAD tools do not act this way. 

I tested this in Altium V19 and it does not work as intended. It's an Altium issue that they must resolve. 



-------------
Stay connected - follow us! https://twitter.com/PCBLibraries" rel="nofollow - Twitter - http://www.linkedin.com/company/pcb-libraries-inc-/" rel="nofollow - LinkedIn



Print Page | Close Window