PCB Libraries Forum Homepage
Forum Home Forum Home > Libraries > Footprints / Land Patterns > Altium
  New Posts New Posts RSS Feed - Wrong generation of Pastе Masks in script for Alt
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Wrong generation of Pastе Masks in script for Alt

 Post Reply Post Reply
Author
Message
kyv4ua View Drop Down
New User
New User


Joined: 08 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kyv4ua Quote  Post ReplyReply Direct Link To This Post Topic: Wrong generation of Pastе Masks in script for Alt
    Posted: 08 Apr 2019 at 4:02am
Wrong generation of Pastе Masks in script for Altium

Pastе Mask in Library Expert Pro 2019.02:


Pastе Mask in Altium Designer v19.0.14 (after run script generated by Library Expert):


script generated by Library Expert:

where is the error, what is done wrong?
Back to Top
kyv4ua View Drop Down
New User
New User


Joined: 08 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kyv4ua Quote  Post ReplyReply Direct Link To This Post Posted: 08 Apr 2019 at 4:34am
I solved the problem by creating two pads per pin:
Solder_Pad
Paste_Pad
Back to Top
kyv4ua View Drop Down
New User
New User


Joined: 08 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kyv4ua Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2019 at 5:27am
Solder_Pad

Paste_Pad


Back to Top
Tom H View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Jan 2012
Location: San Diego, CA
Status: Offline
Points: 4102
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tom H Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2019 at 7:57am
Can you please post the URL datasheet link for this component package? 

We can't reproduce the problem and you seem to be using FP Designer incorrectly. 

Stay connected - follow us! Twitter - LinkedIn
Back to Top
kyv4ua View Drop Down
New User
New User


Joined: 08 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kyv4ua Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2019 at 5:35am
Back to Top
Tom H View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Jan 2012
Location: San Diego, CA
Status: Offline
Points: 4102
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tom H Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2019 at 8:25am
In the Pad Stack Designer: 
  • The Pad Size = 0.65 X 0.35
  • Paste Mask Reduction = -0.15
  • Pad Stack Name = r65_35p35


Stay connected - follow us! Twitter - LinkedIn
Back to Top
kyv4ua View Drop Down
New User
New User


Joined: 08 Apr 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kyv4ua Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2019 at 8:52am
Altium can not cut the mask separately the "x" and "y" axis
Back to Top
Tom H View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Jan 2012
Location: San Diego, CA
Status: Offline
Points: 4102
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tom H Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2019 at 9:21am
Oh, it's a limitation in Altium where the paste must be the same annular ring and therefore you cannot achieve the mfr. recommended paste mask solution. 

You must manually place the correct mfr. recommended paste mask by adding poly-regions on the paste mask layer. 

We'll have to contact Altium and alert them of this issue, because most other CAD tools do not act this way. 

I tested this in Altium V19 and it does not work as intended. It's an Altium issue that they must resolve. 

Stay connected - follow us! Twitter - LinkedIn
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.125 seconds.