PCB Libraries Forum Homepage
Forum Home Forum Home > PCB Library Expert > Questions & Answers
  New Posts New Posts RSS Feed - OrCAD PCB - "Hidden & Deleted Pins" in TO DPAK
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

OrCAD PCB - "Hidden & Deleted Pins" in TO DPAK

 Post Reply Post Reply Page  123>
Author
Message
dmonca View Drop Down
Active User
Active User


Joined: 13 Dec 2012
Location: Switzerland
Status: Offline
Points: 36
Post Options Post Options   Thanks (1) Thanks(1)   Quote dmonca Quote  Post ReplyReply Direct Link To This Post Topic: OrCAD PCB - "Hidden & Deleted Pins" in TO DPAK
    Posted: 07 Feb 2013 at 12:42am
I am currently building our new footprint database for OrCAD PCB Editor and have some issues with the DPAK Footprint.

1. If I build the TO229P990X239-3_4 Footprint, which comes with the FPX library and has only pads 1, 3 and 4 visible, pin 2 also shows up in OrCAD PCB Editor. And even stranger, its orientation is horizontal.



2. If I create a new DPAK footprint, reorder the pin numbers, hide or remove pin number 4 (the pin in the middle) and save it to my own library, the pin shows up again when I reload the footprint.

Footprint after creating  Footprint after reloading
Not reordering the pin numbers does not change the described effect. The pin in the middle stil pops up again on reloading. Am I doing something wrong here?

I downloaded the newest version (V2012-42) but there is no change in the described behaviour.

Thanx for your help.
Regards from Switzerland
Daniel
Back to Top
chrisa_pcb View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 29 Jul 2012
Location: San Diego
Status: Offline
Points: 375
Post Options Post Options   Thanks (1) Thanks(1)   Quote chrisa_pcb Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2013 at 12:21pm
Fixed. It'll be in the next release.
Back to Top
dmonca View Drop Down
Active User
Active User


Joined: 13 Dec 2012
Location: Switzerland
Status: Offline
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmonca Quote  Post ReplyReply Direct Link To This Post Posted: 08 Feb 2013 at 12:00am
Thank you very much Smile. I will try it, as soon as the next version is released Wink
Back to Top
dmonca View Drop Down
Active User
Active User


Joined: 13 Dec 2012
Location: Switzerland
Status: Offline
Points: 36
Post Options Post Options   Thanks (1) Thanks(1)   Quote dmonca Quote  Post ReplyReply Direct Link To This Post Posted: 12 Feb 2013 at 12:02am
Sorry to bother you again. With the new Version (2012-43) the problem changed.
The part from the fpx-library now builds correctly.
However, the second problem that I described above is still present. The hidden pin still shows up on reloading the part. And if I build it, I get the hidden pin in the footprint
Back to Top
dmonca View Drop Down
Active User
Active User


Joined: 13 Dec 2012
Location: Switzerland
Status: Offline
Points: 36
Post Options Post Options   Thanks (1) Thanks(1)   Quote dmonca Quote  Post ReplyReply Direct Link To This Post Posted: 12 Feb 2013 at 12:05am
I forgot something:
If I use the pin hiding feature for example on a soic footprint, it works correctly
Back to Top
Tom H View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Jan 2012
Location: San Diego, CA
Status: Offline
Points: 2013
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tom H Quote  Post ReplyReply Direct Link To This Post Posted: 19 Feb 2013 at 4:29pm
Please download V44 and let us know if this was fixed. Thanks!
Back to Top
dmonca View Drop Down
Active User
Active User


Joined: 13 Dec 2012
Location: Switzerland
Status: Offline
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmonca Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2013 at 5:48am
Hi Tom

Nope. Still the same Problem with V44.

And I now also get PAD-Designer error messages when building THT-Parts
"
PADSTACK ERRORS and WARNINGS:

NCDRILL: Drill hole not defined. Required by BEGIN LAYER layer pads.
NCDRILL: Drill hole not set. Required by internal layer pads.
NCDRILL: Drill hole not defined. Required by END LAYER layer pads.
"

But I think this issue was addressed the post of "sgdavies" (Thru_hole_Allegro_165)
Back to Top
rdl86626 View Drop Down
Advanced User
Advanced User
Avatar

Joined: 20 Jul 2012
Location: Hollister, CA
Status: Offline
Points: 83
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdl86626 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2013 at 9:19am
I am going back to 43. I can not build QFP. It stalls
Back to Top
rdl86626 View Drop Down
Advanced User
Advanced User
Avatar

Joined: 20 Jul 2012
Location: Hollister, CA
Status: Offline
Points: 83
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdl86626 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2013 at 9:33am
I am going back to V43. I cannot build QFP. It stalls...
 
It's not version V44. It just stalls building a Quad Flat No-leads with Tab.
 
Maybe I will try not having the tab and see what happens.
 
Down to the last 2 parts for this board.  Confused
Back to Top
chrisa_pcb View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 29 Jul 2012
Location: San Diego
Status: Offline
Points: 375
Post Options Post Options   Thanks (0) Thanks(0)   Quote chrisa_pcb Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2013 at 10:06am
We had a problem in the packaging for V44 where the holes stopped coming through. That's the drill hole not defined issue. We'll have the fixed version out shortly.
 
As per your other issue, when I follow your instructions and bring the TO part into OrCAD PCB, the pins are showing up correctly.
 
Back to Top
 Post Reply Post Reply Page  123>

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.250 seconds.